??!

Reviews

4.2

6 reviews
5
(4)
4
(1)
3
(0)
2
(0)
1
(1)
  • Build Quality
    4.0 (6)
  • Value for Money
    4.3 (6)
  • Ease of Use
    4.0 (6)
  • Cleaning & Maintenance
    4.5 (6)
Previous
Next

Absolutely Worth the price

published

I bought mine 4 month ago for $450 and I am satisfied. Didn't expect it to be that reliable. Used it now for 4 months in my van and never had problems with it since then. Only problem is the E1 error when you plug it into 12V. Just use the app and set the battery protection to low. After that it works fine.



Purchased in January 2021 at ALDI for A$449.00.

Build Quality
Ease of Use
Cleaning & Maintenance
Value for Money
See all answers
Nathan Curby

Nathan CurbyHunter Region, NSW

Fantastic little fridge/freezer

published

Picked mine up on clearance for $299 three weeks ago. Have just used it camping for 1 week 30+ degrees every day and it worked like a charm. Very very happy. The Bluetooth app is a gimmick and would not connect up most of the time but this doesn't affect the actual main purpose of a fridge/freezer lol

Purchased in December 2021 at ALDI for A$299.00.

Build Quality
Ease of Use
Cleaning & Maintenance
Value for Money
See all answers
Matho12

Matho12MELBOURNE

  • 2 reviews

So Far So Good

published

Have run both on 240v and more recently on 12v using 200w solar blanket at 3 degrees on boat in Gippsland Lakes over last week in plenty of heat and has probably exceeded my expectations



Purchased in September 2021 at ALDI for A$501.00.

Build Quality
Ease of Use
Cleaning & Maintenance
Value for Money
See all answers
Portable Fridges / Freezers

Find out how Roman 50L Portable Fridge Freezer compares to other Portable Fridges / Freezers

Know better, choose better.

Compare all

Need a reliable fridge for my travels

published

First time use after purchase was working on 240 volts will not work on 12 volt and now is intermittant on 240 as well .Aldi return police is excellent but I want a fridge I can rely on .



Purchased in October 2021 at ALDI.

Build Quality
Ease of Use
Cleaning & Maintenance
Value for Money
See all answers

Great looking unit.

published

Only working on 12 volt. . 240 not working. Anyone had same issue. Unit works great on 12v. As soon as plug it into 240v Genny. It not run. Goes into error mode when try to use 12v again

Purchased in September 2021 at ALDI for A$499.00.

Build Quality
Ease of Use
Cleaning & Maintenance
Value for Money
See all answers

works well once you have worked out how to use it.

published

only used it for 3 days for first camping trip not much demand or long usage on it yet, but very impressed the way it worked in hot weather we had one day when it was 28c sitting in a tent. only use it for camping so far. very satisfied with power usage I can run the fridge easy on eco mode for more than 20 hr straight before I hook it back up to sola power.

Purchased in October 2021 for A$499.00.

Build Quality
Ease of Use
Cleaning & Maintenance
Value for Money
See all answers

Questions & Answers

eagle

eagleasked

are the covers on the roman 50ltr car fridge waterproof or water resistant

1 answer
Matho12
Matho12

Not sure, I expect resistant, mine kept in boat to date

Rosemarie E.

Rosemarie E.asked

What number is used for a freezer on the Roman car fridge freezer

No answers
Jared G.

Jared G.asked

So I got this fridge for a steal marked down a few weeks ago for $499. Runs fine on 240. On 12v keeps throwing up E1 and every now and then E3. I used the app dropped the battery protect to low. It seems to do it after about a minute of being on. Had the multimeter on the battery (100ah deep cycle) and goes from 12.7v and randomly spikes down to 7.18v then goes straight back up. Can anyone explain where I have gone wrong.

3 answers
Matho12
Matho12

Sorry no, had no problems over Christmas New Year with 200w blanket and 70amh battery

whatsa
whatsa

if your reading that at frig its because you cabling is too thin... you need thicker wires so voltage drop not high. or you battery is on way out...... try same on car battery if different its your battery

toad
toad

I have one that I've used on 240v with no problems. I use it off the solar system in my bus and have no problem. But, when I use it on the solar system I get the same e1 error you do and it drives me nuts. I think its the quality of the connection to that battery box.
I see on ebay you can get waaco plug to go into an Anderson plug, I am going to measure very carefully to see it the waaco and roman plugs are the same. Or get a better battery box

Get an answer from our members

ieatwords.com.au has affiliate partnerships. These do not influence our content moderation policies in any way, though ieatwords.com.au may earn commissions for products/services purchased via affiliate links.